天道财富网-中国最全面的股票知识学习交流平台!

大智慧指标公式

大智慧红色DDH指标公式

a1:=IF((DATE <= 10805170),1,0);
DRAWTEXTABS(0,0,红色DDH);
a2:=(((CLOSE - (LLV(LOW,9))) / ((HHV(HIGH,9)) - (LLV(LOW,9)))) * 100) * a1;
(SMA(a2,3,1)) * 1.9,colorWhite;
a3:=(SMA(a2,3,1)) * 1.9 - (REF((SMA(a2,3,1)) * 1.9,1));
a4:=VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN)));
a5:=((VOL / (MA(VOL,55))) * 22) * a1;
FILLRGN((SMA(a2,3,1)) * 1.9,(REF((SMA(a2,3,1)) * 1.9,1)),(SMA(a2,3,1)) * 1.9 > (REF((SMA(a2,3,1)) * 1.9,1)),RGB(111,0,0),(SMA(a2,3,1)) * 1.9 < (REF((SMA(a2,3,1)) * 1.9,1)),RGB(0,111,0));
a5 - 22,Color3D;
a6:=MA(VOL,5);
a7:=MA(VOL,13);
a8:=MA(VOL,60);
a9:=EMA(((WINNER((CLOSE * 1.1)) - WINNER((CLOSE * 0.9))) * 20),1);
a10:=EMA((WINNER(CLOSE) * 10),1);
a11:=(a9 - a10) + WINNER(CLOSE);
合:((100 * (CLOSE - (LLV(LOW,5)))) / ((HHV(CLOSE,5)) - (LLV(LOW,5)))) * a1,Color0080FF;
一:((100 * (CLOSE - (LLV(LOW,30)))) / ((HHV(CLOSE,30)) - (LLV(LOW,30)))) * a1,colorYellow;
百:((100 * (CLOSE - (LLV(LOW,10)))) / ((HHV(CLOSE,10)) - (LLV(LOW,10)))) * a1,linethick0,Color008000;
涨:((100 * (CLOSE - (LLV(LOW,20)))) / ((HHV(CLOSE,20)) - (LLV(LOW,20)))) * a1,linethick0,ColorFF8000;
笑脸出手就赢:IF(((((a3 > 7) AND ((REF(a3,1)) < 0)) AND ((a3 - (REF(a3,1))) > 9)) AND a1),(合 + 66),0),STICK,colorWhite;
DRAWICON((笑脸出手就赢 > 0),(合 + 66),1),ALIGN1;
DRAWICON(((CROSS(合,一)) AND a1),-3,7),ALIGN1;
DRAWICON(((CROSS(合,涨)) AND a1),(合 + 88),12),ALIGN1;
DRAWICON(((CROSS(a10,a11)) AND a1),(合 + 11),4),ALIGN1;
a12:=(((((MA(CLOSE,5)) > (MA(CLOSE,10))) AND ((MA(CLOSE,10)) > (MA(CLOSE,30)))) AND ((MA(CLOSE,30)) > (MA(CLOSE,60)))));
a13:=ABS((OPEN - CLOSE));
a14:=HIGH - (IF((CLOSE > OPEN),CLOSE,OPEN));
a15:=(IF((CLOSE > OPEN),OPEN,CLOSE)) - LOW;
a16:=(a13 / (HIGH - LOW)) * VOL;
a17:=(a14 / (HIGH - LOW)) * VOL;
a18:=(a15 / (HIGH - LOW)) * VOL;
DRAWTEXT(((((((a16 > (a6 * 2)) AND (a16 >= a17)) AND (a16 >= a18)) AND (CLOSE > OPEN)) OR ((VOL > (a6 * 3)) AND a12)) AND a1),a5 - 22,'★'),linethick2,ALIGN1,colorRed;
DRAWTEXT((((CROSS(a6,a7)) AND a1) OR ((CROSS(a6,a8)) AND a1)),(a5 - 39),'★'),ALIGN1,colorRed;
a19:=(((VOL / 120) > (a6 / 120)) AND (CLOSE > (OPEN * (1 + (4.8 / 100))))) AND (CLOSE < ((MA(CLOSE,30)) * 1.6));
a20:=IF(((a6 / 120) AND (CLOSE > ((REF(CLOSE,1)) * 1))),8,0);
a21:=IF(((((((CLOSE / (REF(CLOSE,1))) >= 1.05) AND (((VOL / CAPITAL) * 100) < 10)) AND (CLOSE < 18)) AND ((HIGH / CLOSE) < 1.01)) AND (a20 > 0)),10,0);
a22:=((CLOSE - (REF(CLOSE,1))) / (REF(CLOSE,1))) * 100;
a23:=((EMA(CLOSE,12)) - (EMA(CLOSE,26))) * 100;
a24:=(a23 < -50) AND (a22 > 7);
a25:=(a21 > 9) OR a24;
a26:=IF((((CLOSE AND (a6 / 120)) AND (CLOSE > ((REF(CLOSE,1)) * 1))) AND CLOSE),88,0);
a27:=IF(((((((CLOSE / (REF(CLOSE,1))) > 1.05) AND (((VOL / CAPITAL) * 100) < 10)) AND (CLOSE < 17)) AND ((HIGH / CLOSE) < 1.01)) AND (a26 > 0)),91,0);
a28:=a27 > 90;
a29:=HHV((MA((((LOW + HIGH) + CLOSE) / 3),3)),3);
a30:=LLV((MA((((LOW + HIGH) + CLOSE) / 3),3)),5);
a31:=IF(((((((EMA(CLOSE,5)) / (EMA((EMA(CLOSE,9)),16))) <= 0.85) AND ((CLOSE / (REF(CLOSE,1))) > 0.905)) AND ((CLOSE / (REF(CLOSE,1))) < 1.05)) AND (((VOL / CAPITAL) * 100) < 5)),50,0);
a32:=((-100 * ((HHV(HIGH,34)) - CLOSE)) / ((HHV(HIGH,34)) - (LLV(LOW,34)))) + 100;
a33:=((-100 * ((HHV(HIGH,50)) - CLOSE)) / ((HHV(HIGH,50)) - (LLV(LOW,50)))) + 100;
a34:=((-100 * ((HHV(HIGH,70)) - CLOSE)) / ((HHV(HIGH,70)) - (LLV(LOW,70)))) + 100;
a35:=((((CLOSE - (MA(CLOSE,34))) / (MA(CLOSE,34))) * 100) + 10) * 5;
a36:=((((CLOSE - (MA(CLOSE,50))) / (MA(CLOSE,50))) * 100) + 10) * 5;
a37:=((((CLOSE - (MA(CLOSE,70))) / (MA(CLOSE,70))) * 100) + 10) * 5;
a38:=(((((a32 + a33) + a34) + a35) + a36) + a37) / 6;
a39:=EMA(a38,3);
a12:=(ABS((a35 - a37)));
a40:=(a38 + a12) / 2;
a41:=(-1 * ((EMA((100 * (1 - WINNER(CLOSE))),1)) - 50)) + 50;
a42:=a41 + a40;
a43:=IF(((a31 > 0) AND (a42 < 0)),200,0);
a44:=IF((((((a40 < 0) AND (CLOSE = (LLV(CLOSE,5)))) AND ((CLOSE / (REF(CLOSE,1))) > 0.905)) AND ((CLOSE / (REF(CLOSE,1))) < 1.05)) AND (((VOL / CAPITAL) * 100) < 5)),-50,0);
a45:=IF(((a42 < 0) AND (a44 = -50)),100,0);
a46:=MA(CLOSE,3);
a47:=(REF(CLOSE,2)) * 0.865;
a48:=(REF(CLOSE,13)) * 0.772;
a49:=MIN(a47,a48);
a50:=(100 * VOL) / CAPITAL;
天道财富网:{WWW.028178.COM}INDEXADV,COLOR0000EE,NODRAW;
a51:=MA(CLOSE,13);
a52:=IF(((((CLOSE - a49) / CLOSE) < 0.03) AND (((SUM(a50,5)) / 5) < 1.8)),1,0);
a53:=IF(((a52 > 0) AND ((a44 < 0) OR (a31 > 0))),100,0);
a54:=IF((((((a43 > 0) AND (a45 > 0)) AND (((SUM(((VOL / CAPITAL) * 100),5)) / 5) < 1)) OR ((a52 > 0) AND (((REF(CLOSE,1)) / (REF(CLOSE,2))) > 0.902))) OR ((((((a43 > 0) AND (a45 > 0)) AND (((SUM(((VOL / CAPITAL) * 100),5)) / 5) < 1)) OR (a52 > 0)) AND ((a44 < 0) OR (a31 > 0))) AND (a53 < 10))),50,0);
形成底部:(((((((a43 > 0) AND (a45 > 0)) AND (((SUM(((VOL / CAPITAL) * 100),5)) / 5) < 1)) OR (a52 > 0)) AND ((a44 < 0) OR (a31 > 0))) AND a1) OR (((((a43 > 0) AND (a45 > 0)) AND (((SUM(((VOL / CAPITAL) * 100),5)) / 5) < 1)) OR ((a52 > 0) AND (((REF(CLOSE,1)) / (REF(CLOSE,2))) > 0.902))) AND a1)) * 100,linethick2,colorRed;
REF((IF(((((((MA(CLOSE,5)) - CLOSE) / CLOSE) > 0.04) AND ((((MA(CLOSE,10)) - (MA(CLOSE,5))) / (MA(CLOSE,5))) > 0.04)) AND a1),100,0)),1),linethick2,colorRed;
a55:=IF((((REF(CLOSE,1)) < (REF(a29,1))) AND (CLOSE >= a29)),1,0);
DRAWTEXT((((a19 AND a55) AND a1) OR ((a25 AND a28) AND a1)),28,'黑马'),linethick2,ALIGN1,ColorFF8000;
STICKLINE(((((REF(("KDJ.J"),1)) < 0) AND (("KDJ.J") > 0)) AND a1),60,0,1,0),ALIGN1,colorRed;
DRAWTEXT(((((REF(("KDJ.J"),1)) < 0) AND (("KDJ.J") > 0)) AND a1),30,'买'),ALIGN1,colorYellow;

 


TAG: DHH指标公式