天道财富网-中国最全面的股票知识学习交流平台!

大智慧指标公式

拾金图,非常漂亮

DRAWGBK(CLOSE>0,STRIP(RGB(0,128,128),RGB(25,25,112),0));

SSL:=EMA(CLOSE,3);

MMV:=EMA(((SLOPE(CLOSE,22) * 20) + CLOSE),55);

MM:=(IF(((DATATYPE > 5) AND (DATATYPE < 9)),MA(MMV,1),IF((DATATYPE = 5),MA(MMV,4),IF((DATATYPE = 4),MA(MMV,8),IF((DATATYPE = 3),MA(MMV,16),IF((DATATYPE = 2),MA(MMV,32),0))))) );

STICKLINE(((SSL > MM) ),SSL,MM,0.1,0),colorred;

SA:=(MM * 0.985);

SS:=(MA(CLOSE,5));

DD:=(MA(CLOSE,13));

GG:=(MA(CLOSE,21));

财神爷:IF(((SSL > MM)),MM,SA),LINETHICK2,colorFF00FF;

VAR2Y:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);

VAR3Y:=(((CLOSE - REF(OPEN,29)) / REF(OPEN,29)) * 100);

VAR4Y:=REF(CLOSE,1);

VAR5Y:=((SMA(MAX((CLOSE - VAR4Y),0),6,1) / SMA(ABS((CLOSE - VAR4Y)),6,1)) * 100);

VAR6Y:=((SMA(MAX((CLOSE - VAR4Y),0),12,1) / SMA(ABS((CLOSE - VAR4Y)),12,1)) * 100);

VAR7Y:=((SMA(MAX((CLOSE - VAR4Y),0),24,1) / SMA(ABS((CLOSE - VAR4Y)),24,1)) * 100);

VAR8Y:=(((CLOSE - LLV(LOW,45)) / (HHV(HIGH,45) - LLV(LOW,45))) * 100);

VAR9Y:=SMA(VAR8Y,3,1);

VARAY:=SMA(VAR9Y,3,1);

VARBY:=((3 * VAR9Y) - (2 * VARAY));

VARCY:=(CROSS(VAR5Y,10) AND (VAR3Y < (0 - (28 * 20))));

VARDY:=((100 - CROSS(76,VAR5Y)) AND (VAR3Y > (5 * 20)));

DRAWICON(((CROSS(76,VAR5Y) AND (VAR3Y > 5)) ),(HIGH * 1.01),5),colorFFFFFF;

VAREY:=((((CROSS(VAR9Y,VARAY) AND (VARAY < 10)) AND (VAR3Y < (0 - 30))) AND (VAR2Y > 3)) * 30);

VARFY:= - ((((VARAY < 11) AND (VAR5Y < 15)) AND (VAR3Y < (0 - 26))) * 10);

DRAWICON((CROSS(VARFY,(0 - 9))),(LOW * 0.998),4);

能量线:=DMA(((CLOSE + OPEN) / 2),(VOL / (SMA(VOL,4,1) * 4)));

上开:=o;

上收:=c;

上高:=h;

上低:=l;

JJ:=(上开+上高+上低)/3;

A:=EMA(JJ,4);

B:REF(A,1),POINTDOT,COLORYELLOW;

智能黄金线:A,COLORYELLOW,LINETHICK1;

STICKLINE(((SSL < MM) ),财神爷,智能黄金线,0.1,0),COLORCYAN;

VA1:=EMA(上收,8);

VA2:=EMA(上收,20);

DRAWTEXT(CROSS(VA2,VA1),VA1*1.10,'止损'),ALIGN1,COLORyellow;

DRAWTEXT(CROSS(VA1,VA2)AND(C>=O)AND 智能黄金线>REF(智能黄金线,1),VA1*0.98,'★买入'),COLOR00FF00;

选手A:=MA(上收,3);

箱顶A:=MA(REF(HHV(上收,6),1),3);

箱底A:=MA(REF(LLV(上收,3),1),3);

t1:=MA(上收,20)>=REF(MA(上收,20),1);

t2:=CROSS(选手A,箱底A) AND 箱顶A/箱底A>100/100 AND t1;

t3:=CROSS(箱顶A,选手A) AND 箱顶A/箱底A>100/100;

选手:=MA(上收,2);

箱顶:MA(REF(HHV(上收,30),1),2),COLOR0000FF,LINETHICK2;

箱底:MA(REF(LLV(上收,30),1),2),COLOR00FF00,LINETHICK2;

t4:=CROSS(选手,箱底) AND 箱顶/箱底>110/100;

t5:=CROSS(箱顶,选手) AND 箱顶/箱底>110/100;

Var1:=(上收-LLV(上低,27))/(HHV(上高,27)-LLV(上低,27))*100;

Var2:=SMA(Var1,3,1);

Var3:=SMA(Var2,3,1);

Var4:=SMA(Var3,3,1);

DRAWTEXT(Var3 >=Var4 and BARSTATUS=2,箱顶,'--中期好'),COLOR00FFFF;

DRAWTEXT( Var3

DRAWTEXT( A>B and BARSTATUS=2,箱底,'--短期好'),COLOR00FFFF;

DRAWTEXT(A

mms:=ma(sma((l+h+2*c)/4-ref((l+h+2*c)/4,1),5,1)/sma(abs((l+h+2*c)/4-ref((l+h+2*c)/4,1)),5,1)*100,1)+50;

g1:=if(-mms>95,0,20);

uoo:=(-(((CLOSE-LLV(CLOSE,7))/(HHV(CLOSE,7)-LLV(CLOSE,7))*100=100)>0 and g1)+1);

DRAWTEXT(CROSS(Var3,Var4)AND(C>=O)AND Var3<40 AND uoo>0,箱底,'★'),ALIGN0,COLORf00ff0;

DRAWTEXT(CROSS(Var4,Var3) AND Var4>75 ,箱顶*1.03,'★减磅'),COLORf0f000;

{K线}

STICKLINE(C>=O,C,O,7,0),COLORRED;

STICKLINE(C>=O,C,O,4,0),COLORB0B0FF;

STICKLINE(C>=O,C,O,2,0),COLORYELLOW;

STICKLINE(C>=O,H,L,0,0),COLORYELLOW;

STICKLINE(C<=O,C,O,7,0),colorFFAA00;

STICKLINE(C<=O,C,O,4,0),COLORCYAN;

STICKLINE(C<=O,C,O,2,0),COLORCYAN;

STICKLINE(C<=O,H,L,0,0),COLORCYAN;

{K线卖提示}

Qc0:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);

stickline(Qc0>=91 AND (CLOSE-LLV(CLOSE,5))/(HHV(CLOSE,5)-LLV(CLOSE,5))*100>99.9,open,close,3,0),COLOR3366FF;

stickline(Qc0>=91 AND (CLOSE-LLV(CLOSE,5))/(HHV(CLOSE,5)-LLV(CLOSE,5))*100>99.9,H,L,0.5,0),COLOR3366FF;

{K线超卖提示}

SQ1:=SMA(MAX(C-REF(C,2),0),7,1)/SMA(ABS(C-REF(C,2)),7,1)*100;

SQ2:=SMA(MAX(C-REF(C,1),0),7,1)/SMA(ABS(C-REF(C,1)),7,1)*100;

CM1:=IF(SQ1<12,30,0);

CM2:=IF(SQ2<12,30,0);

Zb1:=(CLOSE-LLV(CLOSE,10))/(HHV(CLOSE,10)-LLV(CLOSE,10))*100;

www:=Zb1<1;

w:=if(WWW,-20,0);

A01:=SMA(ABS((LOW - REF(LOW,1))),3,1) / SMA(MAX((LOW - REF(LOW,1)),0),3,1) *100;

A02:=EMA(IF(CLOSE *1.3,A01 *10,A01 /10),3);

A03:=LLV(LOW, 30);

A04:=HHV(A02, 30);

A05:=EMA(IF((LOW <= A03),(A02 + A04*2)/2,0),3) /6180 *2.5;

A06:=IF((A05 >15),15,A05);

Kx:=if(A06>=1.7,-20,0);

Zy:=MA(((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+2*(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100+3*(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100)/6,3);

Zy1:=IF(Zy<-6,-20,0);

KS:=(((CLOSE - SMA(CLOSE,13,1)) / SMA(CLOSE,13,1)) * (0 - 100));

RKS:=REF(KS,1);

MLS:=((((RKS / KS) > 1.23) AND (RKS > 13)) AND ((CLOSE / REF(CLOSE,1)) > 1.03));

{超卖一}STICKLINE(CM1 and IF(Kx and w and Zy1,-16,10)<0,L,L*0.998,7,0),Color0089FF{超卖一:橙};

{超卖二}STICKLINE(IF(Kx and w and Zy1,-16,10)<0 and CM1,L*0.998,L*0.996,7,0),COLORgreen{超卖二:绿};

{超跌}STICKLINE(CM1 and IF(Kx and w and Zy1,-16,10)<0 AND(KS>13),L*0.996,L*0.994,7,0),coloryellow{超跌};

{反弹}STICKLINE((MLS=1),L,L*0.998,7,0),ColorFFFF00;

{K线买提示}

趋势线:=FORCAST(CLOSE,7);

Fk:=100*(C-REF(C,1))/REF(C,1);

pk1:=IF(C

pk2:=IF(C

pk3:=(((CLOSE / OPEN) > 1.04) AND (CLOSE <(SMA(HIGH,21,2) * 1.05))) AND ((CLOSE - REF(CLOSE,1)) > 0);

stickline((Pk1=0 AND REF(Pk1,1)=1 AND Pk2=0 AND REF(Pk2,1)=1),open,CLOSE,3,0),COLORMAGENTA;

stickline((Pk1=0 AND REF(Pk1,1)=1 AND Pk2=0 AND REF(Pk2,1)=1),H,L,0.5,0),COLORMAGENTA;

STICKLINE(pk3 AND(趋势线>REF(趋势线,1)OR 智能黄金线>REF(智能黄金线,1)),CLOSE,OPEN,3,0),COLORMAGENTA;

STICKLINE(pk3 AND(趋势线>REF(趋势线,1)OR 智能黄金线>REF(智能黄金线,1)),H,L,0.5,0),COLORMAGENTA;

买进价:=((c-ref(ma(c,6),1))/6+ma(c,6))*1.004;

买进条件:=cross(c,买进价) and 买进价>ref(买进价,1);

STICKLINE(买进条件 AND 财神爷>智能黄金线 AND 智能黄金线>REF(智能黄金线,1),L,L*0.998,7,0),COLORWHITE;

买线:=EMA(C,2);

卖线:=EMA(SLOPE(C,21)*20+C,42);

DRAWTEXT(cross(买线,卖线)AND 箱顶>=REF(箱顶,1),箱底,'★'),ALIGN0,color00ffff;

stickline(cross(买线,卖线),open,close,3,0),color00ffff;

stickline(cross(买线,卖线),h,l,0.5,0),color00ffff;

A4:=MA(CLOSE,20);

A5:=(CLOSE > MA(CLOSE,5));

A6:=(MA(CLOSE,5) > MA(CLOSE,10));

A7:=(CLOSE > MA(CLOSE,10));

A8:=(MA(CLOSE,5) > MA(CLOSE,20));

A9:=(CLOSE > MA(CLOSE,20));

A10:=REF(A4,1);

A11:=(A4 > A10);

AVX:=(((((IF(A5,10,(0 - 10)) + IF(A6,10,(0 - 10))) + IF(A7,10,(0 - 10))) + IF(A8,10,(0 - 10))) + IF(A9,10,(0 - 10))) + IF(A11,10,(0 - 10)));

DSLX:=(CLOSE / INDEXC);

DSLX1:=MA(DSLX,5);

DSLX2:=MA(DSLX,10);

V1:=MA(VOL,5);

V2:=MA(VOL,10);

阻力位:=IF((CLOSE > 200),(CLOSE * 1.01),(CLOSE * 1.07));

阻力位1:=IF((CLOSE < 10),(CLOSE * 1.05),阻力位);

止损位:=IF((CLOSE > 200),(CLOSE * 0.99),(CLOSE * 0.93));

止损位1:=IF((CLOSE < 10),(CLOSE * 0.95),止损位);

TJTS1:=BARSTATUS=2 and c<200;

TJTS2:=BARSTATUS=2 and c>200;

k2:=hhv(h,barslast(DISPSTATUS=1)+1);

DRAWTEXT(TJTS1 or TJTS2 ,k2*0.99,'阻力位:'+NUMTOSTRN(阻力位1,2)+' '),coloryellow,ALIGN2;

DRAWTEXT(TJTS1 or TJTS2 ,k2*0.99,'止损位:'+NUMTOSTRN(止损位1,2)+' '),coloryellow ,ALIGN2;

DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'该股的量能,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右。 '),ALIGN2,colorDC143C;

DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'该股虽然走势趋强,但量能还显不足,可以考虑短线进场,仓位在1/2左右。 '),ALIGN2,colorDC143C;

DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股量价配合良好,但相对其它股票并没有明显走强,可以考虑短线进场,仓位1/2左右。 '),ALIGN2,colorDC143C;

DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股形态尚可,但量能不足,股票也未完全走强,可以短线参与,仓位1/3左右。 '),ALIGN2,color0000FF;

DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'该股形态变坏,但走势相对其它股票尚可,重仓者减持大半,清仓者可以观望。 '),ALIGN2,color00FF00;

DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'该股随大盘一起下跌,程明显缩量走势,考虑到大盘风险,减持或清仓。 '),ALIGN2,color00FF00;

DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股放量下跌,走势明显偏弱,离场观望。 '),ALIGN2,color00FF00;

DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股缩量下跌,走势偏弱,离场观望。 '),ALIGN2,color00FF00;

DRAWTEXT(TJTS1 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'该股形态良好,强势明显,量能充足,可以继续持有。 '),ALIGN2,color00FFFF;

DRAWTEXT(TJTS1 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'该股上行趋势不变,强势依然,但量能开始转弱,注意风险。 '),ALIGN2,color00FFFF;

DRAWTEXT(TJTS1 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。 '),ALIGN2,color00FFFF;

DRAWTEXT(TJTS1 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股走势趋弱,量能不足,减持大部分筹码。 '),ALIGN2,color00FFFF;

DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'该股形态不佳,注意成交量的变化,但目前不适合参与。 '),ALIGN2;

DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'该股趋势不明,股价偏弱,注意量能变化,目前不宜参与。 '),ALIGN2;

DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股有走强迹象,但量能不足,趋势不明,不适合操作。 '),ALIGN2;

DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股走势太弱,没有参与价值。 '),ALIGN2;

DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 >= V2)) ,k2*0.99,'大盘量能,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右, '),ALIGN2,color0000FF;

DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 >= V2)) ,k2*0.98,' 如前期经过一轮下跌,此时为最佳买点,但如果前期有过一段涨幅则介入需谨慎。 '),ALIGN2,color0000FF;

DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 < V2)) ,k2*0.99,'大盘虽然走势趋强,但量能还显不足,如果前期经过一轮下跌, '),ALIGN2,color0000FF;

DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 < V2)) ,k2*0.98,' 可以考虑短线进场,仓位在1/2左右,一旦量能放大可以加仓买入。 '),ALIGN2,color0000FF;

DRAWTEXT(TJTS2 and (CROSS(1,AVX) AND (V1 >= V2)) ,k2*0.99,'大盘形态走坏,重仓者可以减去大部分仓位。 '),ALIGN2,color00FF00;

DRAWTEXT(TJTS2 and (CROSS(1,AVX) AND (V1 < V2)) ,k2*0.99,'大盘缩量调整,注意风险,短线清仓观望。 '),ALIGN2,color00FF00;

DRAWTEXT(TJTS2 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) ,k2*0.99,'大盘走势良好,量能,可以继续持有强势股。 '),ALIGN2,color00FFFF;

DRAWTEXT(TJTS2 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) ,k2*0.99,'大盘形态良好,但量能稍显不足,随时准备减仓。 '),ALIGN2,color00FFFF;

DRAWTEXT(TJTS2 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) ,k2*0.99,'大盘趋势不明,注意成交量变化,目前不适宜进场。 '),ALIGN2;

DRAWTEXT(TJTS2 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) ,k2*0.99,'大盘趋势向下,量能萎缩,不适合进场。 '),ALIGN2;