天道财富网-中国最全面的股票知识学习交流平台!

大智慧指标公式

波段抄底的公式,供股友们股池参考!波段地量 大盘涨跌比例MACD

波段抄底的公式,供股友们股池参考!

很久不发东西了,只拿不出也不好意思,近来写了几个简单的公式,供做股池的朋友们参考吧!

买卖总口诀:①上升通道(短期:10均线;中长期:30均线); ②高低点(周线、日线); ③基本面(资产、收益,增减持); ④股性; ⑤昨天涨跌幅; ⑥地量结合;

波段地量(日线):有时候信号有点多,结合总口诀和后续指标参考!

REFLINE:0;

ZF:=(c/ref(c,1)-1)*100;

v21:=ema(v,21);

b21:=v/v21;

{5日均线角度}

M5:=MA(CLOSE,5);

x5:=MA(M5,2);

s5:=slope(x5,2)*10;

{系统MACD引用}

diff:="macd.diff";

dea:="macd.dea";

macd:="macd.macd";

{金死叉}

sc:=cross(dea,diff);

jc:=cross(diff,dea);

jbars:=barslast(jc);{上一次金叉周期}

lsbars:=ref(barslast(sc),jbars)+jbars;{上上一次死叉周期}

uptmp:=ref(llvbars(macd,lsbars-jbars),jbars)+jbars;{上涨起始点周期}

{过滤长周期和特殊K线}

upbars:=if(uptmp>13 or uptmp=1,13,uptmp);

{基本限制,同时过滤涨幅和上涨乏力地量--均线角度向下(s5<-0.2)}

base:=s5<-0.2 and ZF>-2;

{波段:上涨起始点以来的地量}

阶段地量:if( base and llv(v,upbars)=v and b21<0.65 ,1,0),colormagenta;

{辅助:相对地量}

相对地量:=base and b21<=0.5;

stickline(相对地量,0,0.5,6,0),coloryellow;

DRAWTEXTABS(0,0,'注:相对地量'),coloryellow;

DRAWTEXTABS(80,0,'阶段地量'),colormagenta;

大盘涨跌比例MACD:

input:SHORT(12,1,999),LONG(26,1,999),M(9,1,999);

涨跌比例:if(date>1140101,100*INDEXADV/(INDEXADV+INDEXDEC),0),colorcyan,linethick0,precis2;

DIFF :EMA(涨跌比例,SHORT) - EMA(涨跌比例,LONG),colorwhite;

DEA : EMA(DIFF,M),coloryellow;

MACD : 2*(DIFF-DEA), COLORSTICK;