天道财富网-中国最全面的股票知识学习交流平台!

大智慧指标公式

经改进的MACD指标

SQX:=(C-MA(CLOSE,13))*100;

diff:EMA(MA(sqx,7),1),COLOR00ffff;

dea:EMA(diff,7),COLORff33ff;macd:(diff-dea)*2,COLORSTICK;

低位金叉:IF(CROSS(DIFF,DEA) AND DIFF<-0.1,0.3,0),COLORYELLOW,POINTDOT;

STICKLINE(低位金叉,0,15,8,0),COLORYELLOW;DRAWICON(低位金叉,0.3,1);

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

二次金叉:IF(CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,0.2,0),COLORff00ff,POINTDOT;

STICKLINE(二次金叉,30,15,8,0),COLORff00ff;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:IF(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),0.1,0),COLORRED,POINTDOT;

STICKLINE(底背离,45,30,8,0),COLORRED;DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED;

A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:REF(CLOSE,A2+1)DIFF AND CROSS(DEA,DIFF),COLORGREEN;

DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN;

A3:=CROSS(DIFF,DEA) AND DEA<0;

零下二次金叉:IF(FILTER(COUNT(A3,21)=2,10),0.05,0),COLORWHITE,POINTDOT;

STICKLINE(零下二次金叉,45,60,8,0),COLORWHITE;