天道财富网-中国最全面的股票知识学习交流平台!

大智慧指标公式

大智慧KDJ+CCI指标公式

DRAWGBKlAST(C>0,strip(RGB(0,0,100),RGB(30,0,30),0));0,COLORff9900;

{KDJ9}

var9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(var9,3,1);

D:SMA(K,3,1),COLOR00FF00,DOTLINE,LINETHICK0;

J:(3*K-2*D),COLOR0000FF,LINETHICK0;

PARTLINE(J*1.5,J*1.5>REF(J*1.5,1),rgb(255,50,0),J*1.5<=REF(J*1.5,1),rgb(0,150,150) ),LINETHICK2,LAYER0;

{大盘KDJ}

{DRSV:=(INDEXC-LLV(INDEXL,9))/(HHV(INDEXH,9)-LLV(INDEXL,9))*100;

DK:=SMA(DRSV,3,1);

DD:=SMA(DK,3,1);

DJ:(3*DK-2*DD),COLORFF44FF,DOTLINE,LINETHICK0;

DJK:(3*DK-2*DD)*1.5,DOTLINE,LINETHICK0;

PARTLINE(DJK,(DJ*1.5>REF(DJK,1))-1,rgb(0,255,0),1,rgb(255,0,0) ),DOTLINE,LINETHICK1,LAYER1;

PARTLINE(DJK,(DJ*1.5>REF(DJK,1))-1,rgb(0,255,0),1,rgb(255,0,0) ),POINTDOT,LINETHICK6,LAYER4;}

{CCI}

TYB:= (HIGH + LOW + 2*CLOSE)/4;

CCIA:=(TYB-MA(TYB,14))/(0.015*AVEDEV(TYB,14));

CCIB:=(TYB-MA(TYB,28))/(0.015*AVEDEV(TYB,28));

CCIC:=(TYB-MA(TYB,42))/(0.015*AVEDEV(TYB,42));

CCI:WMA((CCIA*2+CCIB+CCIC)/4,3);

PARTLINE(CCI,CCI>REF(CCI,1),rgb(255,0,0),CCI<=REF(CCI,1),rgb(0,255,0) ),LINETHICK3;

{大盘CCI}

TYBDP:= (INDEXH + INDEXL + 2*INDEXC)/4;

CCIADP:=(TYBDP-MA(TYBDP,14))/(0.015*AVEDEV(TYBDP,14));

CCIBDP:=(TYBDP-MA(TYBDP,28))/(0.015*AVEDEV(TYBDP,28));

CCICDP:=(TYBDP-MA(TYBDP,42))/(0.015*AVEDEV(TYBDP,42));

CCIDP:=WMA((CCIADP*2+CCIBDP+CCICDP)/4,3);

PARTLINE(CCIDP,(CCIDP>REF(CCIDP,1))-1,rgb(0,255,0),1,rgb(255,0,0) ),DOTLINE,LINETHICK1,LAYER1;

PARTLINE(CCIDP,(CCIDP>REF(CCIDP,1))-1,rgb(0,255,0),1,rgb(255,0,0) ),POINTDOT,LINETHICK6,LAYER4;

XS:FORCAST(((1-BIGORDER(1,1))-(1-BIGORDER(2,1))),5)*1000,LINETHICK0;{小于4万元---反向用}

STICKLINE(XS<0 ,CCI ,CCI-XS,2,0) ,COLOR0099FF,LAYER0;

STICKLINE(XS>0 ,CCI ,CCI-XS,2,0) ,COLORFF9946,LAYER0;

净额主:(bigorder(1,2)-bigorder(2,2))*AMOUNT/10000,linethick0;

DRAWTEXT(BARSTATUS=2,CCI,'【' +NUMTOSTRN(净额主,1)+'万】'),ALIGN0,COLOR00FFFF,LINETHICK3,LAYER0;

{高抛低吸}

SJ:=WMA(((2*C+H+L)/4-LLV(L,5))/(HHV(H,5)-LLV(L,5))*100,2);

ZJ:=WMA(0.618*REF(SJ,1)+0.382*SJ,2);

DRAWTEXT(CROSS(SJ,ZJ) AND SJ<30,-20, ' ▲吸'),ALIGN1,COLOR00FF00,LINETHICK2;

DRAWTEXT(CROSS(ZJ,SJ) AND SJ>70,120, ' ▲抛'),ALIGN1,COLOR0000FF,LINETHICK2;

{BOLL顶底}

MID:=WMA(TYB,18);

UPPER:=MID + 2*STD(TYB,18);

LOWER:=MID - 2*STD(TYB,18);

布顶:STICKLINE(cross(C,UPPER) ,60 ,100 ,8 , 0),color0000FF;

DRAWTEXT(CROSS(C,UPPER) ,90, '顶'),ALIGN1,COLOR00FFFF,LINETHICK1;

布底:STICKLINE(cross(C,LOWER) ,-60 ,-100 ,8 , 0),colorFF9900;

DRAWTEXT(CROSS(C,LOWER) ,-70, '底'),ALIGN1,COLOR00FFFF,LINETHICK1;

倍量:STICKLINE(V>REF(V,1)*2 ,0 ,30 , 8, 1),color00ffff;

DRAWTEXT(V>REF(V,1)*2 ,20, '倍'),ALIGN1,COLOR00FFFF,LINETHICK1;

{标记BSI.KDJ}

LC:=REF(C,1);

RSI:((SMA(MAX((C - LC),0),3,1) / SMA(ABS((C - LC)),3,1)) * 100),LINETHICK0;

DRAWTEXT(DISPSTATUS=2,150,'【RSI:'+NUMTOSTRN(RSI,0)+'】'),COLOR00FFFF,LINETHICK2,ALIGN1;

DRAWTEXT(DISPSTATUS=2,120,'【J:'+NUMTOSTRN(J,1)+'】'),COLOR00FF00,LINETHICK2,ALIGN1;