天道财富网-中国最全面的股票知识学习交流平台!

大智慧指标公式

大智慧极品立桩量主图指标公式

input:时间(71016),N(20,1,100),M(14,1,100);

var1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);

var2:=REF(var1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

var3:=REF(var2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

var4:=REF(var3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

var5:=REF(var4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

var6:=REF(var5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

var7:=REF(var6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

var8:=REF(var7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

var9:=REF(var8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

varA:=REF(var9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

varB:=REF(varA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

varC:=REF(varB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

STICKLINE(var1 OR var2 OR var3 OR var4 OR var5 OR var6 OR var7 OR

var8 OR var9 OR varA OR varB OR varC,CLOSE,REF(CLOSE,1),8,0),COLOR0000AA;{红1}

STICKLINE(var1 OR var2 OR var3 OR var4 OR var5 OR var6 OR var7 OR

var8 OR var9 OR varA OR varB OR varC,CLOSE,REF(CLOSE,1),6,0),COLOR0000CC;{红1}

STICKLINE(var1 OR var2 OR var3 OR var4 OR var5 OR var6 OR var7 OR

var8 OR var9 OR varA OR varB OR varC,CLOSE,REF(CLOSE,1),4,0),COLOR0000DD;{红1}

STICKLINE(var1 OR var2 OR var3 OR var4 OR var5 OR var6 OR var7 OR

var8 OR var9 OR varA OR varB OR varC,CLOSE,REF(CLOSE,1),2,0),COLOR0000FF;{红1}

STICKLINE(var1 OR var2 OR var3 OR var4 OR var5 OR var6 OR var7 OR

var8 OR var9 OR varA OR varB OR varC,CLOSE,REF(CLOSE,1),0,0),COLORYELLOW;{红1}

varD:=CLOSE

varE:=REF(varD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

varF:=REF(varE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

var10:=REF(varF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

var11:=REF(var10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

var12:=REF(var11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

var13:=REF(var12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

var14:=REF(var13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

var15:=REF(var14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

var16:=REF(var15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

var17:=REF(var16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

var18:=REF(var17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

STICKLINE(varD OR varE OR varF OR var10 OR var11 OR var12 OR var13 OR

var14 OR var15 OR var16 OR var17 OR var18,CLOSE,REF(CLOSE,1),8,0),COLOR998855;

STICKLINE(varD OR varE OR varF OR var10 OR var11 OR var12 OR var13 OR

var14 OR var15 OR var16 OR var17 OR var18,CLOSE,REF(CLOSE,1),6,0),COLORBBAA77;

STICKLINE(varD OR varE OR varF OR var10 OR var11 OR var12 OR var13 OR

var14 OR var15 OR var16 OR var17 OR var18,CLOSE,REF(CLOSE,1),4,0),COLORDDCC99;

STICKLINE(varD OR varE OR varF OR var10 OR var11 OR var12 OR var13 OR

var14 OR var15 OR var16 OR var17 OR var18,CLOSE,REF(CLOSE,1),2,0),COLORFFEEBB;

STICKLINE(varD OR varE OR varF OR var10 OR var11 OR var12 OR var13 OR

var14 OR var15 OR var16 OR var17 OR var18,CLOSE,REF(CLOSE,1),0,0),COLORCYAN;

var19:=REF(varD OR varE OR varF OR var10 OR var11 OR var12 OR var13 OR

var14 OR var15 OR var16 OR var17 OR var18,1) AND var1;

STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),8,0),COLOR00ffff;

STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),6,0),COLOR00c8ff;

STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),4,0),COLOR10ecff;

STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR10ffff;

STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),0,0),COLOR10f0ff;

var1A:=REF(var1 OR var2 OR var3 OR var4 OR var5 OR var6 OR var7 OR

var8 OR var9 OR varA OR varB OR varC,1) AND varD;

STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),8,0),COLOR00d900;

STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),6,0),COLOR93ffd1;

STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),4,0),COLOR93ff22;

STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR24ff22;

STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),0,0),COLOR09ff21;

LC:=REF(CLOSE,1);R:=MAX(CLOSE-LC,0)/ABS(CLOSE-LC)*100;

RS:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

M1:=SMA(RS,4,1);

M2:=SMA(R,4,1);

YB:=4*(M1+M2);

DIFF:=EMA(YB,21)-EMA(YB,55);

DEA:=EMA(DIFF,7);

买点:CROSS(DIFF,DEA) AND DEA<0,LINETHICK0;JJ:=BARSLAST(买点);

选股:CROSS(DIFF,DEA)AND COUNT(买点,30)>=2,LINETHICK0;

XM:=CROSS(DEA,DIFF) AND dea>0;

DRAWICON(XM>0,HIGH+0.5,8);

DRAWICON(买点>0,LOW-0.5,7);

DRAWICON(选股>0,LOW-0.5,1);

时间A:=1000000+时间;

时间B:=CURRENTDATE;

d1:=DATE=时间A;

d2:=DATE=时间B;

tj1:=BARSLAST(d1);tj2:=BARSLAST(d2);hh:=HHV(HIGH,tj1);ll:=LLV(LOW,tj1);

hh1:=HHV(VOL,tj1);ll1:=LLV(VOL,tj1);zh:=REF(hh,tj2);zl:=REF(ll,tj2);

zh1:=REF(hh1,tj2);zl1:=REF(ll1,tj2);

sj1:=NUMTOSTR(时间A);

sj2:=NUMTOSTR(时间B);

zw:=BARSLAST(HIGH=hh);jw:=BARSLAST(LOW=ll);zw1:=BARSLAST(VOL=hh1);jw1:=BARSLAST(VOL=ll1);

qz:=(zh-zl)/zl*100*SGN(jw-zw);

qz1:=IF(CAPITAL<1,SUM(INDEXV/EXTDATA(8)*100,tj1),SUM(VOL/CAPITAL*100,tj1));

xs:=NUMTOSTR(REF(DATE,zw));

xx:=NUMTOSTR(REF(DATE,jw));

xs1:=NUMTOSTR(REF(DATE,zw1));

xx1:=NUMTOSTR(REF(DATE,jw1));

A1:=COST(0.33);A2:=COST(5);A3:=COST(15);A4:=COST(55);A5:=COST(97);

成本90:=COST(90);成本70:=COST(70);成本30:=COST(30);成本10:=COST(10);

获利:=WINNER(CLOSE)*100;套牢:=100-WINNER(CLOSE)*100;

DRAWTEXTREL(350,0,'90成本:'+NUMTOSTR(成本90)),Color00DD00;

DRAWTEXTREL(350,60,'70成本:'+NUMTOSTR(成本70)),Color00DDFF;

DRAWTEXTREL(350,120,'30成本:'+NUMTOSTR(成本30)),Color00DD00;

DRAWTEXTREL(350,180,'10成本:'+NUMTOSTR(成本10)),Color00DDFF;

DRAWTEXTREL(350,240,'底出击:'+NUMTOSTR(A1)),ColorDDDDDD;

DRAWTEXTREL(540,0,'建仓:'+NUMTOSTR(A2)),Color00DDFF;

DRAWTEXTREL(700,0,'快刀:'+NUMTOSTR(A3)),Colorff00FF;

DRAWTEXTREL(860,0,'升浪:'+NUMTOSTR(A4)),Color0000FF;

DRAWTEXTREL(860,60,'预测:'+NUMTOSTR(A5)),ColorffFF00;

DRAWTEXTREL(540,60,'获利:'+NUMTOSTR(获利)),ColorFF00FF;

DRAWTEXTREL(700,60,'套牢:'+NUMTOSTR(套牢)),Color00DD00;

DRAWTEXTREL(0,60,'0'+STRMID(xs,3,1)+'年'+STRMID(xs,4,2)+'月'+STRMID(xs,6,2)+'日 '+'最高价:'+NUMTOSTR(REF(HIGH,zw))),COLORFFCC00;

DRAWTEXTREL(0,120,'0'+STRMID(xx,3,1)+'年'+STRMID(xx,4,2)+'月'+STRMID(xx,6,2)+'日 '+'最低价:'+NUMTOSTR(REF(LOW,jw))),COLORFFCC00;

DRAWTEXTREL(0,180,'0'+STRMID(xs1,3,1)+'年'+STRMID(xs1,4,2)+'月'+STRMID(xs1,6,2)+'日 '+'最大量:'+NUMTOSTR(REF(VOL,zw1))),COLORFFCC00;

DRAWTEXTREL(0,240,'0'+STRMID(xx1,3,1)+'年'+STRMID(xx1,4,2)+'月'+STRMID(xx1,6,2)+'日 '+'最低量:'+NUMTOSTR(REF(VOL,jw1))),COLORFFCC00;

DRAWTEXTREL(0,880,'0'+STRMID(sj1,3,1)+'年'+STRMID(sj1,4,2)+'月'+STRMID(sj1,6,2)+'日'),COLORFFCC00;

DRAWTEXTREL(145,880,'到0'+STRMID(sj2,3,1)+'年'+STRMID(sj2,4,2)+'月'+STRMID(sj2,6,2)+'日'),COLORFFCC00;

DRAWTEXTREL(320,880,'这个时间段总跌幅:'+NUMTOSTR(qz)+'%'),COLORFFCC00;

DRAWTEXTREL(320,880,'这个时间段总涨幅:'+NUMTOSTR(qz)+'%'),COLORFFCC00;

DRAWTEXTREL(0,940,'0'+STRMID(sj1,3,1)+'年'+STRMID(sj1,4,2)+'月'+STRMID(sj1,6,2)+'日'),COLORFFCC00;

DRAWTEXTREL(145,940,'到0'+STRMID(sj2,3,1)+'年'+STRMID(sj2,4,2)+'月'+STRMID(sj2,6,2)+'日'),COLORFFCC00;

DRAWTEXTREL(320,940,'这个时间段总换手:'+NUMTOSTR(qz1)+'%'),COLORFFCC00;

DRAWTEXTREL(0,0,STKLABEL+' '+STKNAME+''),Color00DDFF;

X5:=REF(EMA(CLOSE,M),1);

X6:=(EMA(CLOSE,M)-X5)/X5*100;

X7:=REF(EMA(CLOSE,M),BARSLAST(CROSS(X6,0))+1);

X8:=REF(EMA(CLOSE,M),BARSLAST(CROSS(0,X6))+1);

PARTLINE(X8,X6<0 and X8=REF(X8,1)),COLOR00FF00;

PARTLINE(X7,X6>=0 and X7=REF(X7,1)),COLOR0000FF;

DRAWLINE(CROSS(X6,0),X5,CROSS(0,X6),X5,0),COLOR0000FF;

DRAWLINE(CROSS(0,X6),X5,CROSS(X6,0),X5,0),COLOR00EE00;

DRAWLINE(CROSS(0,X6) OR CROSS(X6,0),X5,BARSTATUS=1,X5,0),COLORYELLOW;

AA1:=REF(CLOSE,N)=HHV(CLOSE,2*N+1);

AB1:=FILTER(AA1,N);

AC1:=BACKSET(AB1,N+1);

HD:=FILTER(AC1,N);

AA2:=REF(CLOSE,N)=LLV(CLOSE,2*N+1);

B2:=FILTER(AA2,N);

AC2:=BACKSET(B2,N+1);LD:=FILTER(AC2,N);A:=REF(CLOSE,BARSLAST(HD));

B:=REF(CLOSE,BARSLAST(LD));

t1:=BARSLAST(HD) and BARSLAST(LD) AND NOT(LD);

STICKLINE(t1,A,A,6,0),ColorFFEE00;STICKLINE(t1,B,B,6,0),ColorFF00FF;

VERTLINE(BARSTATUS=2,2),ColorEEEEEE;